uva 562 - Dividing coins

It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.

Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn’t stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...

That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:

• a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag

• a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2

3

2 3 5

4

1 2 4 6

Sample Output

0

1

 

题意:将硬币分成两堆,分得的两堆的差值最小是多少。

假设硬币总和为k,看看获得最接近k/2大小的钱是多少,假设为max_k,则另一个人分得k-max_k,答案即为k-2*max_k。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int T,n,k;
bool f[50005];
void ready()
{
	ios::sync_with_stdio(false),cin.tie(0);
	cin>>T; 
}
void read_in()
{
	memset(f,false,sizeof(f));
	k=0;f[0]=true;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		int a;
		cin>>a;
		for(int j=k;j>=0;j--)
		  if(f[j] && j+a<=50000)
		  {
		  	f[j+a]=true;
		  	k=max(k,j+a); 
		  }
	}
	
}
int get_sum()
{
	for(int i=k/2,j=k/2;i>=0 && j<=k;i--,j++)
	{
		if(f[i])  return i;
		if(f[j])  return j;
	}
}
void work()
{
	read_in();
	int max_sum=get_sum();
	cout<<abs(k-2*max_sum)<<endl;
}
int main()
{ 
	ready();
	while(T--)
	  work();
	return 0;
}

 

全部评论

相关推荐

序&nbsp;朋友们,好久不见。&nbsp;笔者在过去消失的五个月里被困在情绪牢笼中过的相当煎熬,一度丢失自己,觉得整个世界都是昏暗的。&nbsp;庆幸的是靠着自己纯硬扛也是走出来了。表达欲再度回归,所以真的很开心还有机会能在再和大家见面。&nbsp;破碎秋招&nbsp;抑郁情绪的引爆点必然是秋招期间遭受的打击了,从去年九月份腾讯转正被告知失败之后就开始疯狂投递简历,每天都在经历:简历挂、一面挂、二面挂、三面挂、HR面挂,每天睁开眼就被无所适从的挫败感包围。&nbsp;秋招的特点是即便流程走到最后一步也不一定会&nbsp;offer,因为还需要进入大池子进行横向对比,俗称泡池子,而这一泡我的大多数面试流程到后面就没了后文,这一度让我感觉非常绝望。我深知自己学历并...
SoNiC_X:我已经工作快2年了,当时高考没考好没去到想去的学校,觉得天要塌了;校招找不到工作,觉得天要塌了;现在工作觉得看不到未来,觉得天要塌了;最近最大的感悟就是:天会一直塌,但是生活也会一直继续下去,还是要调整好自己的心态,不要因为一时的困难把自己困住,要记住完蛋的日子永远在后头
点赞 评论 收藏
分享
不愿透露姓名的神秘牛友
03-31 21:17
小米 后端 24k*15 硕士985
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务