uva 562 - Dividing coins
It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.
Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn’t stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...
That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.
Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.
Input
A line with the number of problems n, followed by n times:
• a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag
• a line with m numbers separated by one space, each number indicates the value of a coin.
Output
The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.
Sample Input
2
3
2 3 5
4
1 2 4 6
Sample Output
0
1
题意:将硬币分成两堆,分得的两堆的差值最小是多少。
假设硬币总和为k,看看获得最接近k/2大小的钱是多少,假设为max_k,则另一个人分得k-max_k,答案即为k-2*max_k。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int T,n,k;
bool f[50005];
void ready()
{
ios::sync_with_stdio(false),cin.tie(0);
cin>>T;
}
void read_in()
{
memset(f,false,sizeof(f));
k=0;f[0]=true;
cin>>n;
for(int i=1;i<=n;i++)
{
int a;
cin>>a;
for(int j=k;j>=0;j--)
if(f[j] && j+a<=50000)
{
f[j+a]=true;
k=max(k,j+a);
}
}
}
int get_sum()
{
for(int i=k/2,j=k/2;i>=0 && j<=k;i--,j++)
{
if(f[i]) return i;
if(f[j]) return j;
}
}
void work()
{
read_in();
int max_sum=get_sum();
cout<<abs(k-2*max_sum)<<endl;
}
int main()
{
ready();
while(T--)
work();
return 0;
}