字典树经典题目 hdu 1251 统计难题
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.
注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm
ba
b
band
abc
Sample Output
2
3
1
0
分析:这个题就是一个字典树的模板题,只要统计每个结点在添加过程中访问了多少遍,当作一个模板题来做。然后这个题最坑的是数据量没有告诉你,已知RE了很多回,我最后是5*1e5过的,不知道具体数据量是多少
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
const int maxn=5*1e5+10;
struct node
{
int next[27];
int v;
int cnt;
void init()
{
v=0;
cnt=0;
memset(next,-1,sizeof(next));
}
};
struct node L[maxn];
int tot=0;
int add(char a[],int len)
{
int now=0;
for(int i=0; i<len; i++)
{
int tmp=a[i]-'a';
int next=L[now].next[tmp];
if(next==-1)
{
next=++tot;
// L[next].v=-1;
L[next].init();
L[now].next[tmp]=next;
}
L[next].cnt++;//这里就是用来统计该节点访问的次数,其余就是一个模板
now=next;
}
L[now].v=0;
return now;
}
int query(char a[],int len)
{
int now=0;
for(int i=0; i<len; i++)
{
int tmp=a[i]-'a';
int next=L[now].next[tmp];
if(next==-1)return -1;
now=next;
}
return L[now].cnt;
}
int main()
{
char a[11];
L[0].init();
while(gets(a))
{
int t=strlen(a);
if(t==0)break;
int p=add(a,t);
}
while(gets(a))
{
int len=strlen(a);
int ans=query(a,len);
if(ans==-1)printf("0\n");
else printf("%d\n",ans);
}
return 0;
}