HDU 1213 how many tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input <dl><dd> The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
</dd> Output <dd> For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
</dd> Sample Input <dd>
2
5 3
1 2
2 3
4 5

5 1
2 5
</dd> Sample Output <dd>
2
4
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>

using namespace std;

int visitor[1002];
int already[1002];

void chu(int x)
{
	for (int i = 1; i <= x; i++)
	{
		visitor[i] = i;
	}
}

int find(int x)
{
	if (visitor[x] == x)
	{
		return x;
	}
	else return visitor[x] = find(visitor[x]);
}

bool friendfind(int x)
{
	for (int i = 0; already[i] != 0; i++)
	{
		if (already[i] == x)
		{
			return false;
		}
	}
	return true;
}

int main()
{
	int n;
	cin >> n;
	while (n--)
	{
		
		int visitor_num, guan;
		cin >> visitor_num >> guan;
		int v1, v2;
		chu(visitor_num);
		memset(already, 0, sizeof(already));
		for (int i = 0; i < guan; i++)
		{
			cin >> v1 >> v2;
			visitor[find(v1)] = visitor[find(v2)];
		}
		
		int k = 0;
		for (int i = 1; i <= visitor_num; i++)
		{
			int temp = find(visitor[i]);
			if (friendfind(temp))
			{
				already[k++] = temp;
			}
		}
		cout << k<<'\n';
		
	}
	return 0;
}

//by swust_y_p
</dd></dl>
全部评论

相关推荐

Yushuu:你的确很厉害,但是有一个小问题:谁问你了?我的意思是,谁在意?我告诉你,根本没人问你,在我们之中0人问了你,我把所有问你的人都请来 party 了,到场人数是0个人,誰问你了?WHO ASKED?谁问汝矣?誰があなたに聞きましたか?누가 물어봤어?我爬上了珠穆朗玛峰也没找到谁问你了,我刚刚潜入了世界上最大的射电望远镜也没开到那个问你的人的盒,在找到谁问你之前我连癌症的解药都发明了出来,我开了最大距离渲染也没找到谁问你了我活在这个被辐射蹂躏了多年的破碎世界的坟墓里目睹全球核战争把人类文明毁灭也没见到谁问你了😆
点赞 评论 收藏
分享
10-09 19:35
门头沟学院 Java
洛必不可达:java的竞争激烈程度是其他任何岗位的10到20倍
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务