HDU2016 A - Bone Collector (01背包)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input <dl><dd> The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. </dd> Output <dd> One integer per line representing the maximum of the total value (this number will be less than 2 31). </dd> Sample Input <dd>
1
5 10
1 2 3 4 5
5 4 3 2 1
</dd> Sample Output <dd>

14


坑点在于有一种物体体积为0==
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>


using namespace std;

struct node
{
	int len, large;
};

int dp[1000][1005];
node goods[1005];

int main()
{
	int n;
	scanf("%d", &n);
	while (n--)
	{
		memset(dp, 0, sizeof(dp));
		memset(goods, 0, sizeof(goods));
		int num, large;
		scanf("%d %d", &num, &large);
		for (int i = 0; i < num; i++)
		{
			scanf("%d", &goods[i].large);
		}
		for (int i = 0; i < num; i++)
		{
			scanf("%d", &goods[i].len);
		}

		for (int i = 0; i < num; i++)
		{
			for (int j = 0; j <=large; j++)
			{
				if (i == 0)
				{
					if (j >= goods[i].len )
					{
						dp[i][j] = goods[i].large;
					}
					else
					{
						dp[i][j] = 0;
					}
				}

				else
				{
					if (j >= goods[i].len)
					{
						dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - goods[i].len] + goods[i].large);
					}
					else
					{
						dp[i][j] = dp[i - 1][j];
					}
				}

			}
		}


		printf("%d\n", dp[num - 1][large]);
	}
	return 0;
}
//by swust t_p
</dd></dl>
全部评论

相关推荐

11-04 14:10
东南大学 Java
_可乐多加冰_:去市公司包卖卡的
点赞 评论 收藏
分享
10-15 09:13
已编辑
天津大学 soc前端设计
点赞 评论 收藏
分享
评论
点赞
1
分享
牛客网
牛客企业服务