HDU1498-二分图行列匹配
50 years, 50 colors
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2498 Accepted Submission(s): 1410
Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".
There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
Sample Output
-1 1 2 1 2 3 4 5 -1
给你一个n*n的矩阵,矩阵中每个格子对应一种颜色的气球,问你踩n次,每次只能选择一行或一列踩掉一种颜色的所有气球,最后还剩余的气球颜色有哪些
题目思路:
首先看下数据范围,气球颜色只有50种最多,矩阵大小100*100最大,所以我们可以枚举每种颜色,对于每种颜色,我们进行行列匹配,x为一个集合,y为一个集合,最后匹配到的最大匹配数就是踩掉所有气球所需的最小次数,这个应该不难想到,如果画个图来理解就是最小点覆盖,而最小点覆盖=最大匹配!
AC代码:
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 105;
int n,k;
int link[maxn],a[55],matrix[maxn][maxn];
bool vis[maxn],mp[maxn][maxn];
bool dfs(int u){
for(int i=1;i<=n;i++){
if(!vis[i]&&mp[u][i]){
vis[i]=true;
if(link[i]==-1||dfs(link[i])){
link[i]=u;
return true;
}
}
}
return false;
}
int main()
{
while(scanf("%d%d",&n,&k),n+k){
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
scanf("%d",&matrix[i][j]);
a[matrix[i][j]]=1;
}
}
int flag=1;
for(int i=1;i<=50;i++){
if(!a[i])continue; //枚举每种颜色,a[i]记录该种颜色有没有出现过
memset(mp,false,sizeof(mp));
memset(link,-1,sizeof(link));
int num = 0;
for(int j=1;j<=n;j++)
for(int l=1;l<=n;l++)
if(matrix[j][l]==i)mp[j][l]=true;
for(int j=1;j<=n;j++){
memset(vis,false,sizeof(vis));
if(dfs(j))num++;
}
if(num>k){
if(flag){printf("%d",i);flag=0;}
else printf(" %d",i);
}
}
if(flag)printf("-1");
printf("\n");
}
return 0;
}