poj1703(Find them, Catch them)并查集

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题意:有两个犯罪团伙,给你n个罪犯的信息,D x y表示x和y不是同一个团伙的,A x y表示询问x和y是否是同一个团伙或者不能确定。


题解:参考了《挑战程序设计竞赛》上面的例题解法,很不错!和poj1128有异曲同工之妙!用并查集,x表示x在a团伙,x+n表示x在b团伙,D x y就合并x,y+n和x+n,y。查询时如果x,y或者x+n,y+n在一起,就是一个团伙的,如果x,y+n或者x+n,y在一起就不是一个团伙的,否则无法确定。这方法不错,感觉比网上位运算类别偏移好理解多了,也好写。


#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

const int maxn = 100010;

int f[maxn*2];

int Find(int x)
{
    return x == f[x] ? x : (f[x] = Find(f[x]));
}

void join(int x, int y)
{
    int fx = Find(x), fy = Find(y);
    f[fx] = fy;
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n, m;
        cin >> n >> m;
        for (int i = 1; i <= 2*n; ++i)
            f[i] = i;
        char s[5];
        while (m--)
        {
            int x, y;
            scanf("%s%d%d", s, &x, &y);
            if (s[0] == 'D')
            {
                join(x, y+n);
                join(x+n, y);
            }
            else
            {
                if (Find(x) == Find(y) || Find(x+n) == Find(y+n))
                    printf("In the same gang.\n");
                else
                    if (Find(x) == Find(y+n) || Find(x+n) == Find(y))
                        printf("In different gangs.\n");
                    else
                        printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}


算法码上来 文章被收录于专栏

公众号「算法码上来」。godweiyang带你学习算法,不管是编程算法,还是深度学习、自然语言处理算法都一网打尽,更有各种计算机新鲜知识和你分享。别急,算法码上来。

全部评论

相关推荐

面试摇了我吧:啊哈哈面试提前五个小时发,点击不能参加就是放弃
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务