HD1004(Let the Balloon Rise)

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

#include <iostream>
#include <string>
#include <map>
#include <algorithm>
#include <vector>
using namespace std;

bool cmp(const pair<string, int> &n1, const pair<string, int> &n2)
{
    return n1.second > n2.second;
}

int main(int argc, char const *argv[])
{
    int n = 0;
    //用map存储键值对,然后排序后输出...
    map<string, int> s;
    while (cin >> n && n != 0)
    {
        string in;
        for (int i = 0; i < n; ++i)
        {
            cin >> in;
            s[in]++;
        }
        vector<pair<string, int>> vec(s.begin(), s.end());
        std::sort(vec.begin(), vec.end(), cmp);
        vector<pair<string, int>>::iterator iter = vec.begin();
        cout << iter->first << endl;
        s.clear();
    }
    return 0;
}

全部评论

相关推荐

我在朝九晚六双休的联想等你:如果我是你,身体素质好我会去参军,然后走士兵计划考研211只需要200多分。
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务