PAT-1003-Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.
Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

数组的初始化问题,要学会用fill()函数,dijikstra算法模板要牢记

#include <iostream>
using namespace std;
#define INF 10000000
/** * N 城市数 * M 马路数 * C1 起点 * C2 终点 */
int N,M,C1,C2 = 0;
/** * m 存储两个城市之间的距离 * dis 最短距离数组 * team 存储每个城市的救援队数 * vis 标记城市是否已经访问 * **/
int m[500][500],dis[500],team[500],res[500],path[500],vis[500];

void Dijikstra(int begin){
    int min,pos;
    fill(dis,dis+500,INF);
    fill(res,res+500,0);
    fill(path,path+500,0);
    fill(vis,vis+500,0);
    dis[C1] = 0;
    res[C1] = team[C1];
    path[C1] = 1;
    for(int i=0;i<N;++i){
        min = INF;
        for(int j=0;j<N;++j){
            if(!vis[j]&&dis[j]<min){
                pos = j;
                min = dis[j];
            }
        }
        vis[pos] = true;
        for(int v=0;v<N;++v){
            if(!vis[v] && m[pos][v]!=INF){
                if(dis[v]>dis[pos]+m[pos][v]){
                    dis[v] = dis[pos]+m[pos][v];
                    res[v] = res[pos] + team[v];
                    path[v] = path[pos];
                }else if(dis[v] == dis[pos]+m[pos][v]){
                    path[v]+=path[pos];
                    res[v] = max(res[v],res[pos]+team[v]);
                }
            }
        }
    }
}

int main(int argc, char const *argv[])
{
    fill(m[0],m[0]+500*500,INF);
    cin >> N >> M >> C1 >> C2;
    for(int i=0;i<N;++i){
        cin >> team[i];
    }
    int c1,c2;
    for(int i=0;i<M;++i){
        cin >> c1 >> c2 ;
        cin>> m[c1][c2];
        m[c2][c1] = m[c1][c2];
    }
    Dijikstra(C1);
    cout << path[C2] << " " << res[C2];
    return 0;
}
全部评论

相关推荐

点赞 评论 收藏
分享
点赞 评论 收藏
分享
评论
点赞
收藏
分享
正在热议
# 25届秋招总结 #
441069次浏览 4495人参与
# 春招别灰心,我们一人来一句鼓励 #
41545次浏览 524人参与
# 北方华创开奖 #
107339次浏览 599人参与
# 地方国企笔面经互助 #
7937次浏览 18人参与
# 同bg的你秋招战况如何? #
75837次浏览 554人参与
# 虾皮求职进展汇总 #
114640次浏览 885人参与
# 阿里云管培生offer #
119974次浏览 2219人参与
# 实习,投递多份简历没人回复怎么办 #
2454217次浏览 34849人参与
# 实习必须要去大厂吗? #
55703次浏览 960人参与
# 提前批简历挂麻了怎么办 #
149846次浏览 1977人参与
# 投递实习岗位前的准备 #
1195775次浏览 18547人参与
# 你投递的公司有几家约面了? #
33182次浏览 188人参与
# 双非本科求职如何逆袭 #
661978次浏览 7394人参与
# 如果公司给你放一天假,你会怎么度过? #
4734次浏览 55人参与
# 机械人春招想让哪家公司来捞你? #
157608次浏览 2267人参与
# 如果你有一天可以担任公司的CEO,你会做哪三件事? #
11417次浏览 276人参与
# 发工资后,你做的第一件事是什么 #
12467次浏览 61人参与
# 工作中,努力重要还是选择重要? #
35657次浏览 384人参与
# 参加完秋招的机械人,还参加春招吗? #
20096次浏览 240人参与
# 我的上岸简历长这样 #
451947次浏览 8088人参与
# 实习想申请秋招offer,能不能argue薪资 #
39252次浏览 314人参与
# 非技术岗是怎么找实习的 #
155859次浏览 2120人参与
牛客网
牛客企业服务