poj1459Power Network(最大流EK算法)
题目链接:点击打开链接
文章转载自:xuanqis.com
Description
A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output
15
6
Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.
寻找增光路的算法
- 每次寻找到一条增光路
- 对寻找到的增光路,找到一个最大的但是又满足容量限制的minflow。就是说找出这个增光路的最小的那条边。
- 对于增光路的所有前向弧增加minflow,后向弧减去minflow。
- 一直重复前面的,直到找不到了增光路,这个时候的就是最大流。
代码
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#define SIZE 210
using namespace std;
int map[SIZE][SIZE]; //两点间的流量
int pre[SIZE];
int n, np, nc, m;
queue<int> myque;
bool bfs(int src, int des){ //找出从源点到汇点的一个流,有则返回true,否则返回false
memset(pre,-1,sizeof(pre)); //pre设置为-1
while(!myque.empty()) myque.pop(); //清空队列
pre[src]=0; //源点的前缀为0
int index;
myque.push(src);
while(!myque.empty()){ //队列如果空了,说明没有从源点到汇点的流
index = myque.front();
myque.pop();
for(int i=0;i<=1+n;i++){ //对于n+1的点,看看有没有可走到且没走过的点
if(pre[i] == -1 && map[index][i] > 0){
pre[i]=index;
if(i == des) return true; //如果走到汇点,那么就已经找到了可行的流
myque.push(i);
}
}
}
return false; //没有流了
}
int MaxFlow(int src, int des){
int maxflow=0;
while(bfs(src,des)){ //没有流,就已经是最大流了
int minflow = (1<<30); //设置为无穷大
int i;
for(i=des;i!=src;i=pre[i]){ //找出那条流,并且算出这条流中最小的瓶颈
minflow=min(minflow,map[pre[i]][i]);
}
for(i=des;i!=src;i=pre[i]){ //对于这条流,构***向边,正向边减多少,反向边加多少
map[pre[i]][i] -= minflow;
map[i][pre[i]] += minflow;
}
maxflow += minflow; //最大流加上这个流的流量
}
return maxflow; //返回去
}
int main(){
int src, des; //定义起点终点
int u, v, w; //临时变量,可分别作为边的起点终点权值
char ss[30]; //作为输入数据所用,因为有空格
while(~scanf("%d%d%d%d", &n, &np, &nc, &m)){ //输入点数 发电站数 消耗站数 边数
memset(map, 0, sizeof(map)); //设置为0
src = n; //以n作为超级源点
des = n+1; //以n+1作为超级汇点
for(int i=0;i<m;i++){ //输入边和最大传输量
scanf("%s",ss);
sscanf(ss,"(%d,%d)%d", &u, &v, &w);
map[u][v]=w; //单向
}
for(int i=0;i<np;i++){ //输入发电站,超级源点到发电站的传输量就设置为发电站的电量
scanf("%s", ss);
sscanf(ss, "(%d)%d", &v, &w);
map[src][v]=w; //从超级源点到发电站
}
for(int i=0;i<nc;i++){ //输入耗电站,耗电站到超级汇点的传输量就设置为耗电站的电量
scanf("%s",ss);
sscanf(ss,"(%d)%d", &u, &w);
map[u][des]=w; //耗电站到超级汇点
}
printf("%d\n",MaxFlow(src,des)); //算出从超级源点到超级汇点的最大流
}
return 0;
}