PAT-A 1027. Colors in Mars
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input
Each input file contains one test case which occupies a line containing the three decimal color values.
Output
For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.
Sample Input
15 43 71
Sample Output
#123456
程序代码:
#include<stdio.h>
char r[3]={0};
char g[3]={0};
char b[3]={0};
void convert(char* s,int n);
int main()
{
int red,green,blue;
scanf("%d%d%d",&red,&green,&blue);
convert(r,red);
convert(g,green);
convert(b,blue);
printf("#%s%s%s",r,g,b);
return 0;
}
void convert(char* s,int n)
{
if(n<13)
{
s[0] = '0';
if(n<10)
s[1]=n+'0';
else
s[1]=n-10+'A';
}
else
{
if((n%13)<10)
s[1]=n%13+'0';
else
s[1]=n%13-10+'A';
if((n/13)<10)
s[0]=n/13 + '0';
else
s[0]=n/13-10+'A';
}
s[2]='\0';
}