PAT-A 1094. The Largest Generation
1094. The Largest Generation
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
这道题其实考的是图的BFS遍历,如果当成树来看的话会比较麻烦,因为孩子的个数是不确定的。还是看成一个特殊的图来看待比较方便。C++当中有很多很好用的容器,比如queue、stack等等,可怜我之前用C,全部都要自己写,真是蠢到姥姥家了。这道题比较麻烦的是计算每一层的结点个数,用两重for循环可以解决这个问题。
程序代码:
#include<iostream>
using namespace std;
#define MAX 100
#include<queue>
#include<vector>
vector <int> num[MAX];
bool visited[MAX]={0};
void BFS(int s);
int sum = 0;
int max_level =1;
int main()
{
int N,M; //N总人数,M有孩子的人数
cin>>N>>M;
int ID,k;
int tmp;
for(int i=0;i<M;i++)
{
cin>>ID>>k;
for(int j=0;j<k;j++)
{
cin>>tmp;
num[ID].push_back(tmp);
}
}
BFS(1);
cout<<sum<<" "<<max_level;
return 0;
}
void BFS(int s)
{
int level =1;
//max_level = 1;
int cnt,cnt1=1;
//max = 0;
queue<int> q;
q.push(s);
visited[s]=true;
int tmp;
while(!q.empty())
{
cnt=cnt1;
cnt1=0;
if(cnt>sum)
{
sum = cnt;
max_level = level;
}
for(int j=0;j<cnt;j++)
{
tmp = q.front();
q.pop();
visited[tmp]= true;
for(int i=0;i<num[tmp].size();i++)
{
q.push(num[tmp][i]);
cnt1++;
}
}
level++;
}
}