PAT-A 1004.Counting Leaves

1004. Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

这道题跟1094题是一样的思路,就是图的BFS遍历而已。
程序代码:

#include<iostream>
#include<queue>
#include<vector>
#define MAX 100
using namespace std;
int l[MAX]={0};
vector<int> num[MAX];
void BFS(int s,int* level);
int main()
{
    int N,M,ID,k,tmp;
    int level = 1;
    cin>>N>>M;
    for(int i=0;i<M;i++)
    {
        cin>>ID>>k;
        for(int j=0;j<k;j++)
        {
            cin>>tmp;
            num[ID].push_back(tmp);
        }
    }
    BFS(1,&level);
    for(int i=1;i<=level;i++)
    {
        cout<<l[i];
        if(i<level)
            cout<<' ';
    }
    return 0;
}
void BFS(int s,int* level)
{
    queue<int> q;
    q.push(s);
    int count=1;
    int cnt;
    int tmp;
// int level = 1;
    int count0=0;
    while(!q.empty())
    {
        cnt = count;
        count = 0;
        //l[*level]=count0;
        count0=0;
        for(int i=0;i<cnt;i++)
        {
            //count0=0;
            tmp = q.front();
            q.pop();
            if(num[tmp].size()==0)
                count0++;   
            else
            {
                for(int j=0;j<num[tmp].size();j++)
                {
                    q.push(num[tmp][j]);
                    count++;
                }   
            }
        }
        l[*level]=count0;
        (*level)++;
    }
    (*level)--;
    //l[*level]=count0;
}
全部评论

相关推荐

字节 飞书绩效团队 (n+2) * 15 + 1k * 12 + 1w
点赞 评论 收藏
分享
AI牛可乐:哇,听起来你遇到了什么挑战呢!🐮牛可乐在这里,虽然小,但是勇敢又聪明,想听听你的具体情况哦!如果你愿意的话,可以点击我的头像给我私信,我们可以一起想办法应对挑战,好不好呀?🌟🎉
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务