HDU 1702 ACboy needs your help again!

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor :(. 
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :” I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy.” 
The problems of the monster is shown on the wall: 
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”). 
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer). 
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.

Output

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input


4 FIFO 
IN 1 
IN 2 
OUT 
OUT 
4 FILO 
IN 1 
IN 2 
OUT 
OUT 
5 FIFO 
IN 1 
IN 2 
OUT 
OUT 
OUT 
5 FILO 
IN 1 
IN 2 
OUT 
IN 3 
OUT

Sample Output







None 

3

题目大意:

输入a,表示a组测试数据,输入b和s表示接下来有b行命令,s表示是栈还是队列,s为FIFO表示队列,s为FILO为栈,命令为IN表示后面跟的数字进栈(队),OUT表示出栈顶(队首)元素出栈(队),当栈(队)为空时,执行OUT输出None。

C++

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<queue>
using namespace std;
int main()
{
    int a,b,c,d,e;
    string s,n;
    cin>>a;
    while(a--)
    {
        cin>>b>>s;
        if(s=="FIFO")
        {
            queue<int>m;
            while(b--)
            {
                cin>>n;
                if(n=="IN")
                {
                    cin>>d;
                    m.push(d);
                }
                else
                {
                    if(m.empty())
                        cout<<"None"<<endl;
                    else
                    {
                        d=m.front();
                        m.pop();
                        cout<<d<<endl;
                    }
                }
            }
        }
        else if(s=="FILO")
        {
            stack<int>m;
            while(b--)
            {
                cin>>n;
                if(n=="IN")
                {
                    cin>>d;
                    m.push(d);
                }
                else
                {
                    if(m.empty())
                        cout<<"None"<<endl;
                    else
                    {
                        d=m.top();
                        m.pop();
                        cout<<d<<endl;
                    }
                }
            }
        }
    }
    return 0;
}





全部评论

相关推荐

冷艳的小师弟在看机会:jd测评乱点直接被挂了,哭死~
点赞 评论 收藏
分享
孤寡孤寡的牛牛很热情:为什么我2本9硕投了很多,都是简历或者挂,难道那个恶心人的测评真的得认真做吗
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务