HDU 1548 A strange lift

题目链接:传送门

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?


Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0


Sample Output

3

题目大意:这是一个奇怪的电梯,每层只有一个数字,表示能上下的层数。问能否从a层到达b层,如果能,输出需要按的次数,如果不能,输出-1.

输入由多组测试用例组成,每个测试用例包含两行。第一行包含三个整数n,a,b(1<=n,a,b<=200),n表示总层数,a表示开始层数,b表示目标层数。第二行包含n个整数k1,k2,….kn。单个0表示输入的结束。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int m[205],n[205];
int s,w,z;
struct node{
	int x,y;
};
int bfs()
{
	queue<node>qu;
	int a,b,c,d,e;
	node next,head;
	head.x=w;
	head.y=0;
	n[w]=1;
	qu.push(head);
	while(!qu.empty())
	{
		head=qu.front();
		qu.pop();
		if(head.x==z)
		{
			cout<<head.y<<endl;
			return 1;
		}
		next.x=head.x+m[head.x-1];
		next.y=head.y+1;
		if(n[next.x]==0&&next.x<=s)
		{
			qu.push(next);
			n[next.x]=1;
		}
		next.x=head.x-m[head.x-1];
		next.y=head.y+1;
		if(n[next.x]==0&&next.x>=0)
		{
			qu.push(next);
			n[next.x]=1;
		}
	}
	return 0;
}
int main()
{
	int a,b,c;
	while(cin>>s)
	{
		if(!s)
			break;
		cin>>w>>z;
		for(a=0;a<s;a++)
		{
			cin>>m[a];
		}
		memset(n,0,sizeof(n));
		if(bfs()==0)
			cout<<-1<<endl;
	}
	return 0;
}

 

全部评论

相关推荐

10-24 13:36
门头沟学院 Java
Zzzzoooo:更新:今天下午有hr联系我去不去客户端,拒了
点赞 评论 收藏
分享
去B座二楼砸水泥地:不过也可以理解,这种应该没参加过秋招
点赞 评论 收藏
分享
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务