n个1

Description
由n个1组成的整数能被K(K<10000)整除,n至少为多少?
Input
多组测试数据,第一行输入整数T,表示组数 然后是T行,每行输入1个整数代表K
Output
对于每组测试数据输出1行,值为n
Sample Input
1
11
Sample Output
2

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {
	int t;
	while(scanf("%d",&t)!=EOF){
		
		int i;
		for(i=1;i<=t;i++){
			int k;
    		scanf("%d",&k);
    		if(k==1){
    		printf("%d\n",1);
    		continue;
    		}
    		unsigned long n=1;
    		int c=1;
    		int temp=1;
    		while(temp!=0){ 
     			temp=temp*10+1;
     			temp=temp%k;
     			c++; 
     		} 	
    			printf("%d\n",c);
    			
		}
	} 
	return 0;
}
全部评论

相关推荐

有趣的牛油果开挂了:最近这个阶段收到些杂七杂八的短信是真的烦
点赞 评论 收藏
分享
AI牛可乐:哇,听起来你遇到了什么挑战呢!🐮牛可乐在这里,虽然小,但是勇敢又聪明,想听听你的具体情况哦!如果你愿意的话,可以点击我的头像给我私信,我们可以一起想办法应对挑战,好不好呀?🌟🎉
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务