Japan

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
#include <iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include <stdio.h>
using namespace std;
const int N=1010;
int t,n,m,k,M,s[N];
struct node{
    int x,y;
    bool operator <(const node &b)const{
        if(x==b.x)
            return y<b.y;
        return x<b.x;
}
} a[N*N];
int lowbit(int x){
    return x&(-x);
}
void updata(int x,int y){
    while(x<=m){
        s[x]+=y;
        x+=lowbit(x);
    }
}
int query(int x){
    int sum=0;
    while(x){
        sum+=s[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    scanf("%d",&t);

    for(int T=1;T<=t;T++){
        scanf("%d%d%d",&n,&m,&k);
        //M=max(m,n);
        memset(s,0,sizeof(s));
        for(int K=1;K<=k;K++){
            scanf("%d%d",&a[K].x,&a[K].y);
        }
        sort(a+1,a+k+1);
        long long  ans=0;
        for(int i=1; i<=k; i++)
        {
            updata(a[i].y,1);
            ans+=(query(m)-query(a[i].y));
        }
        printf("Test case %d: %lld\n",T,ans);
    }
    //cout << "Hello world!" << endl;
    return 0;
}

 

全部评论

相关推荐

11-09 14:54
已编辑
华南农业大学 产品经理
大拿老师:这个简历,连手机号码和照片都没打码,那为什么关键要素求职职位就不写呢? 从上往下看,都没看出自己到底是产品经理的简历,还是电子硬件的简历? 这是一个大问题,当然,更大的问题是实习经历的描述是不对的 不要只是去写实习流程,陈平,怎么去开会?怎么去讨论? 面试问的是你的产品功能点,是怎么设计的?也就是要写项目的亮点,有什么功能?这个功能有什么难处?怎么去解决的? 实习流程大家都一样,没什么优势,也没有提问点,没有提问,你就不得分 另外,你要明确你投的是什么职位,如果投的是产品职位,你的项目经历写的全都是跟产品无关的,那你的简历就没用 你的面试官必然是一个资深的产品经理,他不会去问那些计算机类的编程项目 所以这种四不像的简历,在校招是大忌
点赞 评论 收藏
分享
10-11 17:45
门头沟学院 Java
走吗:别怕 我以前也是这么认为 虽然一面就挂 但是颇有收获!
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务