sdnu1483.Problem_A(位运算+大数)

Description

Check whether an integer n is a power of 2.

Input

First line contains a single integer T (T<=20000000) which denotes the number of test cases. For each test case, there is an big integer N(0 < N < 2^1000)

Output

For each case, output the "Yes" or "No" in a single line.

Sample Input

3
1
3 
8

Sample Output

Yes
No
Yes

位运算判断是否是2的整数次幂(x-1)& x == 0  是  else不是

ps:是否是4的整数次幂:if((x&0x55555555)==x) 是 else 不是

python真强 !

t = int(input())
while t > 0:
    a = int(input())
    if (a - 1) & a == 0:
        print("Yes")
    else:
        print("No")
    t = t - 1

 

全部评论

相关推荐

拒绝无效加班的小师弟很中意你:求职意向没有,年龄、课程冗余信息可以删掉,需要提升项目经历。排版需要修改。
点赞 评论 收藏
分享
粗心的雪碧不放弃:纯学历问题,我这几个月也是一直优化自己的简历,后来发现优化到我自己都觉得牛逼的时候,发现面试数量也没有提升,真就纯学历问题
点赞 评论 收藏
分享
1 收藏 评论
分享
牛客网
牛客企业服务