POJ - 3186 Treats for the Cows (区间dp)
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.
The treats are interesting for many reasons:
- The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
- Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
- The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
- Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?
The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5 1 3 1 5 2
Sample Output
43
Hint
Explanation of the sample:
Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
题意:
有 n 个数排成一行,每次可以取左右两端的数,第 k 次取数的贡献是 k * a[i],求最大贡献值
思路:
这里用逆过程,即从这一行数中取出一个数,剩下的数必须在取出的数的左右两侧取。dp[i][j]表示区间 [i, j] 都取完得到的最大值,可以由dp[i + 1][j]和dp[i][j - 1]推过来
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const double eps = 1e-8;
const int N = 2e3 + 10;
int a[N], dp[N][N];
int main()
{
int n, t;
while(~scanf("%d", &n))
{
for(int i = 1; i <= n; ++i)
{
scanf("%d", &a[i]);
dp[i][i] = a[i] * n; //先把每个都当成最后一个取走的,贡献值为 n 倍
}
for(int i = n; i >= 1; --i)//枚举起点
{
for(int j = i + 1; j <= n; ++j)//枚举终点
{
dp[i][j] = max(dp[i + 1][j] + a[i] * (n - j + i), dp[i][j - 1] + a[j] * (n - j + i)); //一种是最近取的是a[i],一种是最近取的a[j]
}
}
cout<<dp[1][n]<<'\n'; //整个区间都取完了
}
return 0;
}