POJ - 2777 Count Color(线段树 + 状态压缩)

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

题意:

进行两种操作:

(1)给区间内涂上某种颜色

(2)求某一区间内不同颜色的数量

思路:

由于颜色种数比较少,可以使用状态压缩,用二进制数的每一位代表一种颜色

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <queue>
#include <map>
using namespace std;
typedef long long ll;
const int N = 1e5 + 10;
const int inf = 0x3f3f3f3f;

int sum[N << 2], add[N << 2];

void push_up(int rt)
{
    sum[rt] = sum[rt << 1] | sum[rt << 1 | 1];
}

void push_down(int rt)
{
    if(add[rt])
    {
        add[rt << 1] = add[rt << 1 | 1] = add[rt];
        sum[rt << 1] = sum[rt << 1 | 1] = add[rt];
        add[rt] = 0;
    }
}

void build(int l, int r, int rt)
{
    sum[rt] = add[rt] = 0;
    if(l == r)
    {
        sum[rt] = 1;
        return ;
    }
    int m = (l + r) >> 1;
    build(l, m, rt << 1);
    build(m + 1, r, rt << 1 | 1);
    push_up(rt);
}

void update(int L, int R, int C, int l, int r, int rt)
{
    if(L > r || R < l) return ;
    if(L <= l && R >= r)
    {
        add[rt] = 1 << (C - 1);
        sum[rt] = 1 << (C - 1);
        return ;
    }
    push_down(rt);
    int m = (l + r) >> 1;
    update(L, R, C, l, m, rt << 1);
    update(L, R, C, m + 1, r, rt << 1 | 1);
    push_up(rt);
}

int query(int L, int R, int l, int r, int rt)
{
    if(L > r || R < l) return 0;
    if(L <= l && R >= r) return sum[rt];
    int m = (l + r) >> 1;
    push_down(rt);
    return query(L, R, l, m, rt << 1) | query(L, R, m + 1, r, rt << 1 | 1);
}

int main()
{
    int L, T, O;
    scanf("%d%d%d", &L, &T, &O);
    build(1, L, 1);
    for(int i = 1; i <= O; ++i)
    {
        getchar();
        char op;
        int l, r, k;
        scanf("%c%d%d", &op, &l, &r);
        if(l > r)
            swap(l, r);
        if(op == 'C')
        {
            scanf("%d", &k);
            update(l, r, k, 1, L, 1);
        }
        else
        {
            int ans = query(l, r, 1, L, 1);
            int cnt = __builtin_popcount(ans);///求某个数二进制中1的个数
            printf("%d\n", cnt);
        }
    }
    return 0;
}

 

全部评论

相关推荐

10-14 10:56
已编辑
长沙学院 嵌入式软件开发
痴心的00后拿到了ssp:hr面挂了,无所谓了反正不去😃
点赞 评论 收藏
分享
10-16 09:58
已编辑
门头沟学院 Java
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务