【归并排序求逆序对】poj1007
DNA Sorting
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
求出每个串的逆序对的个数,然后按逆序对个数对DNA串进行排序。
求逆序对的方法是用归并排序
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct ty
{
long x;
string s;
inline bool operator < (const ty& b) const
{
if (x < b.x) return true;
else return false;
}
};
long n, m;
string t;
ty a[200];
long sum;
void merge1(long l, long mid, long r)
{
char tmp1[200] = {"\0"}, tmp2[200] = {"\0"};
for (long i = l; i <= mid; i++)
{
tmp1[i] = t[i];
}
for (long i = mid + 1; i <= r; i++)
{
tmp2[i] = t[i];
}
tmp1[mid + 1] = 'Z';
tmp2[r + 1] = 'Z';
long i = l , j = mid + 1;
for (long k = l; k <= r; k++)
{
if (tmp1[i] <= tmp2[j])
{
t[k] = tmp1[i];
i++;
}
else{
t[k] = tmp2[j];
sum +=mid - i + 1;
j++;
}
}
}
void merge_sort(long l, long r)
{
if (l <r)
{
long mid = (l + r) / 2;
merge_sort(l, mid);
merge_sort(mid + 1, r);
merge1(l, mid, r);
}
}
long nixudui(long i)
{
sum = 0;
t = a[i].s;
merge_sort(0, m - 1);
return sum;
}
int main()
{
freopen("G.in","r",stdin);
while (scanf("%d%d\n", &m, &n) != EOF)
{
for (long i = 1; i<= n; i++)
{
cin >> a[i].s;
a[i].x = nixudui(i);
}
sort(a + 1, a + 1 + n);
for (long i = 1; i<= n; i++)
{
cout << a[i].s<<endl;
}
}
return 0;
}