【floyd】poj1125

Stockbroker Grapevine

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
题目读了好久……英语太渣了!
大意给出n个点,m条边及边的权值,求之中的一个点,使其到每个点的最大距离最小。
思路:floyd求出每个两点之间距离,再扫描一遍就可以了
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const long N = 110;
const long INF = 2 ^ 30;
long f[N][N];
long n;
void init()
{
    memset(f, 127, sizeof(f));
    for (long i = 1; i <= n; i++)
    {
        long tmp;
        scanf("%d", &tmp);
        for (long j = 1; j <= tmp ; j++)
        {
            long x, l;
            scanf("%d%d", &x, &l);
            f[i][x] = l;
        }
    }
}
void floyd()
{
    for (long k = 1; k <= n; k++)
        for (long i = 1; i <= n; i++)
            for (long j = 1; j <= n; j++)
                if ((i != j)&&(j != k)&&(k != i)&&(f[i][k] <= 100000)&&(f[k][j] <= 100000))
                {
                    if (f[i][k] + f[k][j] <= f[i][j])
                        f[i][j] = f[i][k] + f[k][j];

                }
}
int main()
{
    freopen("poj1125.in", "r", stdin);
    while (scanf("%d", &n), n != 0)
    {
        init();
        floyd();
        long maxn = INF, dian = 0;
        for (long i = 1; i <= n; i++)
        {
            long minn = 0;
            for (long j = 1; j <= n; j++)
            {
                if ((i != j)&&(f[i][j] > minn))
                    minn = f[i][j];
            }

            if (minn < maxn)
            {
                maxn = minn;
                dian = i;
            }
        }
    }
    return 0;
}


 
全部评论

相关推荐

预计下个星期就能开奖吧,哪位老哥来给个准信
华孝子爱信等:对接人上周说的是这周
投递华为等公司10个岗位 >
点赞 评论 收藏
分享
爱看电影的杨桃allin春招:我感觉你在炫耀
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务