Grid Compression(删除行和列)

问题 B: Grid Compression

时间限制: 1 Sec  内存限制: 128 MB

题目描述

There is a grid of squares with H horizontal rows and W vertical columns. The square at the i-th row from the top and the j-th column from the left is represented as (i,j). Each square is black or white. The color of the square is given as an H-by-W matrix (ai,j). If ai,j is ‘.‘, the square (i,j) is white; if ai,j is '#', the square (i,j) is black.
Snuke is compressing this grid. He will do so by repeatedly performing the following operation while there is a row or column that consists only of white squares:
Operation: choose any one row or column that consists only of white squares, remove it and delete the space between the rows or columns.
It can be shown that the final state of the grid is uniquely determined regardless of what row or column is chosen in each operation. Find the final state of the grid.
Constraints
1≤H,W≤100
ai,j is '.' or '#'.
There is at least one black square in the whole grid.

 

输入

Input is given from Standard Input in the following format:

H W
a1,1…a1,W
:
aH,1…aH,W

 

 

输出

Print the final state of the grid in the same format as input (without the numbers of rows and columns); see the samples for clarity.

 

 

样例输入

复制样例数据

4 4
##.#
....
##.#
.#.#

样例输出

###
###
.##

 

提示

The second row and the third column in the original grid will be removed.

/**/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <stack>
#include <queue>

typedef long long LL;
using namespace std;

int n, m;
char s[105][105];
int l[105], r[105];

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);

	scanf("%d %d", &n, &m);
	for (int i = 1; i <= n; i++){
		scanf("%s", s[i] + 1);
	}
	for (int i = 1; i <= n; i++){
		int t = 0;
		for (int j = 1; j <= m; j++){
			if(s[i][j] == '.'){
				t++;
			}
		}
		if(t == m) l[i] = 1;
	}
	for (int i = 1; i <= m; i++){
		int t = 0;
		for (int j = 1; j <= n; j++){
			if(s[j][i] == '.'){
				t++;
			}
		}
		if(t == n) r[i] = 1;
	}
	for (int i = 1; i <= n; i++){
		int flag = 0;
		for (int j = 1; j <= m; j++){
			if(l[i] || r[j]) continue;
			flag = 1;
			printf("%c", s[i][j]);
		}
		if(flag) printf("\n");
	}

	return 0;
}
/**/

 

全部评论

相关推荐

不愿透露姓名的神秘牛友
11-24 20:55
阿里国际 Java工程师 2.7k*16.0
程序员猪皮:没有超过3k的,不太好选。春招再看看
点赞 评论 收藏
分享
10-14 23:01
已编辑
中国地质大学(武汉) Java
CUG芝士圈:虽然是网上的项目,但最好还是包装一下,然后现在大部分公司都在忙校招,十月底、十一月初会好找一些。最后,boss才沟通100家,别焦虑,我去年暑假找第一段实习的时候沟通了500➕才有面试,校友加油
点赞 评论 收藏
分享
11-29 11:21
门头沟学院 Java
总包48.5w,意想不到的价格
无情咸鱼王的秋招日记之薛定谔的Offer:R
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务