poj3734(Blocks)快速幂+组合数学

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6


题意:n个方块排成一列,每块可以涂成红蓝绿黄四种颜色,问红色方块和绿色方块个数同时为偶数的方案有多少种?


题解:设ai, bi, ci分别表示到第i块为止红绿都是偶数、红绿有一个是偶数、红绿都是奇数方案数,那么

ai+1 = 2ai + bi

bi+1 = 2ai + 2bi + 2ci

ci+1 = bi + 2ci

写成矩阵形式后用快速幂即可求解


#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

typedef vector<int> vec;
typedef vector<vec> mat;
const int Mod = 10007;

mat mul(mat& a, mat& b)
{
    mat c(3, vec(3));
    for (int i = 0; i < 3; ++i)
        for (int k = 0; k < 3; ++k)
            for (int j = 0; j < 3; ++j)
                c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % Mod;
    return c;

}

mat pow(mat& a, int n)
{
    mat b(3, vec(3));
    for (int i = 0; i < 3; ++i)
        b[i][i] = 1;
    while (n > 0)
    {
        if (n&1)
            b = mul(b, a);
        a = mul(a, a);
        n >>= 1;
    }
    return b;
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n;
        scanf("%d", &n);
        mat a(3, vec(3));
        a[0][0] = 2; a[0][1] = 1; a[0][2] = 0;
        a[1][0] = 2; a[1][1] = 2; a[1][2] = 2;
        a[2][0] = 0; a[2][1] = 1; a[2][2] = 2;
        a = pow(a, n);
        printf("%d\n", a[0][0]);
    }
    return 0;
}


算法码上来 文章被收录于专栏

公众号「算法码上来」。godweiyang带你学习算法,不管是编程算法,还是深度学习、自然语言处理算法都一网打尽,更有各种计算机新鲜知识和你分享。别急,算法码上来。

全部评论

相关推荐

循此苦旅:月初笔试全a,没面试!
点赞 评论 收藏
分享
躺尸修仙中:因为很多92的也去卷中小厂,反正投递简历不要钱,面试不要钱,时间冲突就推,不冲突就面试积累经验
点赞 评论 收藏
分享
经纬恒润 后端开发 比美团少8k
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务