A1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

#include <iostream>
#include <vector>
#include <queue>
#define Max 100
using namespace std;
void INPUT(int, int);
void OUTPUT();
typedef struct Node
{
    int id;
    vector<int> children;
    Node(int id) { this->id = id; }
} _NODE_;

vector<Node> NODES(Max, Node(0));
vector<int> ans;
int main(int argc, char const *argv[])
{
    int N, M;
    INPUT(N, M);
    OUTPUT();
    return 0;
}
//建立树
void INPUT(int N, int M)
{
    cin >> N >> M;
    int ID, NUM;
    for (int i = 0; i < M; ++i)
    {
        scanf("%d", &ID);
        NODES[ID].id = ID;
        scanf("%d", &NUM);
        for (int j = 0; j < NUM; ++j)
        {
            int nid;
            scanf("%d", &nid);
            NODES[ID].children.push_back(nid);
        }
    }
}
void OUTPUT()
{
    //层序遍历
    queue<Node> q;
    q.push(NODES[1]);
    int t = 1;
    int s = q.size();
    int count = 0;
    while (!q.empty())
    {
        Node h = q.front();
        int cs = h.children.size();
        if (cs == 0)
        {
            count++;
        }
        else
        {
            for (int i = 0; i < cs; ++i)
            {
                q.push(NODES[h.children[i]]);
            }
        }
        q.pop();
        s = q.size();
        t = t - 1;
        if (t == 0)
        {
            ans.push_back(count);
            count = 0;
            t = s;
        }
    }
    int k = 0;
    for (; k < ans.size() - 1; ++k)
    {
        cout << ans[k] << " ";
    }
    cout << ans[k];
}

全部评论

相关推荐

巧克力1:双选会不如教室宣讲会
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务