PAT(进制转换)——1015 Reversible Primes (20 分)
1015 Reversible Primes (20 分)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10
5
) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
题目大意:
如果一个数本身是素数,并且转换为以d为基数反转过来仍然是素数,则输出yes。
题目解析:
一开始理解错了题意,翻转过来还是要以d为基数翻转。
具体代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define N 11000
bool isprime(int n) {
if(n <= 1) return false;
int sqr = int(sqrt(n * 1.0));
for(int i = 2; i <= sqr; i++) {
if(n % i == 0)
return false;
}
return true;
}
int convert(string n,int d){
int num=0;
for(int i=0;i<n.size();i++){
num=d*num+(n[i]-'0');
}
return num;
}
int resort(int n){
int num=0;
while(n!=0){
num=num*10+n%10;
n/=10;
}
return num;
}
int main()
{
int n;
int d;
while(cin>>n){
if(n<0) break;
cin>>d;
if(isprime(n)){
char A[20];
int top=0;
do{
A[top++]=n%d+'0';
}while(n/=d);
for(int i=0;i<top;i++){
n=n*d+(A[i]-'0');
}
if(isprime(n))
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
else
cout<<"No"<<endl;
}
return 0;
}