PAT(树)——1106 Lowest Price in Supply Chain (25 分)

1106 Lowest Price in Supply Chain (25 分)
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10
​5
​​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K
​i
​​ ID[1] ID[2] … ID[K
​i
​​ ]

where in the i-th line, K
​i
​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K
​j
​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10
​10
​​ .

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

题目大意:

给出一棵供货关系的树,根节点0代表总供应商,叶子节点是零售商,每往下一级价格上涨r%,求价格最低的零售商和个数。

题目解析:

结构体+dfs。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
struct node{
	int level;
	vector<int> child;
}A[100100];
void dfs(int root){
	for(int i=0;i<A[root].child.size();i++){
		int child=A[root].child[i];
		A[child].level=A[root].level+1;
		dfs(child);
	}
}
int main()
{
    int n;
	double p,r;
    scanf("%d%lf%lf",&n,&p,&r);
    for(int i=0;i<n;i++){
    	int k;
    	scanf("%d",&k);
    	for(int j=0;j<k;j++){
    		int child;
    		scanf("%d",&child);
    		A[i].child.push_back(child);
		}
	}
	A[0].level=0;
	dfs(0);
	int minlevel=99999,minnum=0;
	for(int i=0;i<n;i++){
		if(A[i].child.size()==0)
			if(A[i].level<minlevel){
				minlevel=A[i].level;
				minnum=1;
			}else if(A[i].level==minlevel)
				minnum++;
	}
	printf("%.4f %d",p*pow((r/100+1),minlevel),minnum);
    return 0;
}
全部评论

相关推荐

不愿透露姓名的神秘牛友
11-24 20:55
阿里国际 Java工程师 2.7k*16.0
程序员猪皮:没有超过3k的,不太好选。春招再看看
点赞 评论 收藏
分享
10-25 00:32
香梨想要offer:感觉考研以后好好学 后面能乱杀,目前这简历有点难
点赞 评论 收藏
分享
10-13 17:47
门头沟学院 Java
wulala.god:图一那个善我面过,老板网上找的题库面的
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务