PAT(dfs)——1103. Integer Factorization (30)
The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n1^P + … nK^P
where ni (i=1, … K) is the i-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen — sequence { a1, a2, … aK } is said to be larger than { b1, b2, … bK } if there exists 1<=L<=K such that ai=bi for ibL
If there is no solution, simple output “Impossible”.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
题目大意
dfs+剪枝
题目解析:
这个题目一开始怎么提交都超时,本来以为dfs剪枝写的有问题,借鉴了别人的代码还是超时,后来发现问题出在了init函数,这个地方是要取一个尽可能小的上界的。
修改前 :
void init() {
for(int i=0; i<=n; i++)
N.push_back(pow(i,p));
}
修改后:
void init() {
for(int i=0; i<=n; i++){
int temp=pow(i,p);
if(temp>n) return;
N.push_back(temp);
}
}
具体代码:
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
#define MAXN 400
vector<int> N,res,A;
int maxsum=-1;
int n,k,p;
void init() {
for(int i=0; i<=n; i++){
int temp=pow(i,p);
if(temp>n) return;
N.push_back(temp);
}
}
void dfs(int tempsum,int sum,int i,int index) {
if(i==k){
if(tempsum==n&&sum>maxsum) {
maxsum=sum;
res=A;
}
}
else
while(index>=1){
if(tempsum+N[index]<=n){
A[i]=index;
dfs(tempsum+N[index],sum+index,i+1,index);
}
if(index==1)
return;
index--;
}
}
int main() {
cin>>n>>k>>p;
A.resize(k);
init();
dfs(0,0,0,N.size()-1);
if(maxsum==-1) {
printf("Impossible");
return 0;
}
printf("%d = ",n);
for(int i=0; i<k; i++) {
printf("%d^%d",res[i],p);
if(i!=k-1)
printf(" + ");
}
return 0;
}