PAT(stl)——1100 Mars Numbers (20 分)

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earch is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:
4
29
5
elo nov
tam
Sample Output:
hel mar
may
115
13

题目大意:

一道20分的模拟水题,花了1个小时才通过。具体看代码。

题目解析:

具体代码:

#include<iostream>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;
string x[13]={"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string y[13]={"undefined","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
map<string,int> m;
void init(){
	for(int i=0;i<13;i++){
		m[x[i]]=i;
		m[y[i]]=i*13;
	}
}
int main()
{
    int n;
    cin>>n;
    init();
    getchar();
    while(n--){
    	string s;
    	getline(cin,s);
    	if(isdigit(s[0])){//处理数字 
			int num=stoi(s);
			int arr[3],k=0;
			do{
				arr[k++]=num%13;
			}while(num/=13);
			if(k>1){//有十位
				cout<<y[arr[1]];
				if(arr[0]!=0)
					cout<<" "<<x[arr[0]];
				cout<<endl;
			}else{
				cout<<x[arr[0]]<<endl;
			}
		}else{
			string tmp;
			int num=0;
			for(int i=0;i<s.size();i++){
				if(s[i]==' '){
					num+=m[tmp];
					tmp.clear();
				}else
					tmp+=s[i];
			}
			num+=m[tmp];
			cout<<num<<endl;
		}
	}
    return 0;
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务