PAT(链表)——1032. Sharing (25)-PAT甲级真题
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.
Snip20160807_66
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
题目大意:
如果两个单词后缀相同,输出共同后缀的起始位置。
题目解析:
用结构体保存下一个字母的位置和状态flag,从第一个单词的起始位置出发,一直遍历到结尾,沿途的字母的状态都设为true;再从第二个字母出发遍历,遇到状态为true的字母就是所求的。没有就输出-1。
具体代码:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 100005
struct node{
int nextid;
bool flag;
}A[MAXN];
int main()
{
int s1,s2,n;
scanf("%d%d%d",&s1,&s2,&n);
while(n--){
int pre,post;
char c;
scanf("%d %c %d",&pre,&c,&post);
A[pre].nextid=post;
}
while(s1!=-1){
A[s1].flag=true;
s1=A[s1].nextid;
}
while(s2!=-1&&A[s2].flag==false)
s2=A[s2].nextid;
if(s2==-1){
printf("-1");
return 0;
}else{
printf("%05d",s2);
}
return 0;
}