PAT(二叉搜索树)——1043. Is It a Binary Search Tree (25)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
题目大意:
判断所给的序列是否是二叉搜索树的前序遍历序列或者镜像序列。
题目解析:
按所给序列生成二叉搜索树,然后进行判断。
具体代码:
#include<iostream>
#include<algorithm>
using namespace std;
int arr[1005];
bool flag;
int k;
struct node{
int data;
node *left;
node *right;
node(int v){
data=v;
left=NULL;
right=NULL;
}
}*Root;
void insert(node *root,int v){
if(root->data>v){//左小
if(root->left==NULL)
root->left=new node(v);
else
insert(root->left,v);
}else{
if(root->right==NULL)
root->right=new node(v);
else
insert(root->right,v);
}
}
void pre(node *root){
if(root==NULL||flag==false)
return;
if(root->data!=arr[k++])
flag=false;
pre(root->left);
pre(root->right);
}
void swap(node *root){
if(root==NULL)
return;
swap(root->left);
swap(root->right);
node *tmp=root->left;
root->left=root->right;
root->right=tmp;
}
void post(node *root){
if(root==NULL)
return;
post(root->left);
post(root->right);
if(root==Root)
cout<<root->data;
else
cout<<root->data<<" ";
}
int main()
{
int n;
cin>>n;
cin>>arr[0];
Root=new node(arr[0]);
for(int i=1;i<n;i++){
cin>>arr[i];
insert(Root,arr[i]);
}
judge(Root);
flag=true,k=0;
pre(Root);
if(flag==true){
cout<<"YES"<<endl;
post(Root);
return 0;
}
flag=true,k=0;
swap(Root);
pre(Root);
if(flag==true){
cout<<"YES"<<endl;
post(Root);
}else
cout<<"NO"<<endl;
return 0;
}