PAT(二叉搜索树)——1064. Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

题目大意:

给出一串序列,构建成一个完全二叉搜索树,然后层次遍历。

题目解析:

这道题本来看到题觉得太绕都想放弃了,看了别人的代码后大有启发。

  • 首先,因为所给的序列是二叉搜索树,所以从小到大按顺序排列就能得到他的中序遍历序列
  • 其次,因为又满足完全二叉树,所以,如果根为i(从0开始计算),左子2i+1,右子2i+2。如此便可以根据给出的中序序列构建二叉树。

具体代码:

#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 1005
int tree[MAXN],ans[MAXN];
int n,index=0;
void create(int root){
	if(root<n){
		create(root*2+1);
		tree[root]=ans[index++];
		create(root*2+2);
	}
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
    	cin>>ans[i];
    sort(ans,ans+n);
    create(0);
    for(int i=0;i<n;i++){
    	if(i==n-1)
    		cout<<tree[i];
    	else
    		cout<<tree[i]<<" ";
	}
    return 0;
}
全部评论

相关推荐

头像
10-15 22:27
已编辑
门头沟学院 C++
罗格镇的小镇做题家:我投了hr打电话来说学历太低了不符合要求,建议投荣耀,结果荣耀也投了一定水花没有,非本211硕
投递华为等公司10个岗位
点赞 评论 收藏
分享
dongsheng66:如果想进大厂的话,在校经历没必要占这么大篇幅,可以把专业技能单独放一个专栏写,可以加个项目经历
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务