PAT-A 1031. Hello World for U

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

程序代码:

#include<stdio.h>
#include<string.h>
#define MAX 10000
char c[MAX]={0};
void space(int n);
int main()
{
    scanf("%s",c);
    int len = strlen(c);
    int n1,n2;
    if((len+2)%3==0){
        n2 = (len+2)/3;
        n1 = ((len+2)-n2)/2;
    }
    else if((len+2)%3==1){
        n2 = (len+2)/3+1;
        n1 = (len+2-n2)/2;
    }
    else{
        n2 = (len+2)/3+2;
        n1 = ((len+2)-n2)/2;
    }
    int i=0,j=len-1;
    while(n1>1){
        putchar(c[i++]);
        space(n2-2);
        putchar(c[j--]);
        putchar('\n');
        n1--;
    }
    for(;i<=j;i++)
        putchar(c[i]);
    return 0;
}
void space(int n)
{
    int i=0;
    for(i=0;i<n;i++)
        putchar(' ');
}
全部评论

相关推荐

过往烟沉:我说什么来着,java就业面就是广!
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务