PAT-A 1035. Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

程序代码:

#include<stdio.h>
#define MAX 1001
int modify(char a[],int flag[],int i);
int main()
{
    int n,i,flag[MAX]={0};
    char name[MAX][11];
    char password[MAX][11];
    int count=0;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%s %s",name[i],password[i]);
    }
    for(i=0;i<n;i++)
    {
        count+=modify(password[i],flag,i);
    }
    if(count==0)
    {   
        if(n>1)
            printf("There are %d accounts and no account is modified",n);
        else
            printf("There is 1 account and no account is modified");
    }
    else
    {
        printf("%d\n",count);
        for(i=0;i<n;i++)
        {
            if(flag[i]==1)
            printf("%s %s\n",name[i],password[i]);
        }
    }   
    return 0;
}
int  modify(char a[],int flag[],int i)
{
    char *p=a;
    while(*p!='\0')
    {
        switch (*p)
        {
            case '1':{*p='@',flag[i]=1;}break;
            case '0':{*p='%',flag[i]=1;}break;
            case 'l':{*p='L',flag[i]=1;}break;
            case 'O':{*p='o',flag[i]=1;}break;
            default:break;
        }
        p++;        
    }
    if(flag[i]==1)
        return 1;
    else
        return 0;
}
全部评论

相关推荐

明天不下雨了:我靠2022了都去字节了还什么读研我教你****:你好,本人985电子科大在读研一,本科西南大学(211)我在字节跳动实习过。对您的岗位很感兴趣,希望获得一次投递机会。
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务