ACM-ICPC 2018 焦作赛区网络预赛 I. Save the Room (真签到)

题目:

Bob is a sorcerer. He lives in a cuboid room which has a length of AA, a width of BB and a height of CC, so we represent it as AA * BB * CC. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 11 * 11 * 22 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

Input

Input has TT test cases. T \le 100T≤100

For each line, there are three integers A, B, CA,B,C.

1 \le A, B, C \le 1001≤A,B,C≤100

Output

For each test case, if Bob can save his room, print"Yes", otherwise print"No".

样例输入复制

1 1 2
1 1 4
1 1 1

样例输出复制

Yes
Yes
No

题目来源

ACM-ICPC 2018 焦作赛区网络预赛


题解:

同样是一道水题。

此题的思路就是说,现在提供一个长宽高分别为a,b,c的长方体,判断能不能用1*1*2的长方体将其填满。

因为是1*1*2所以比较简单,只有一种情况下不成立那就是当最后剩余一个1*1*1的块时候。即体积只要能够满足为偶数即可。


代码:

#include <stdio.h>
int main(){
	int a,b,c,d;
	while(scanf("%d %d %d",&b,&c,&d)!=EOF){
		if(b*c*d%2!=0){
			printf("NO\n");
		}else{
			printf("YES\n"); 
		}
	} 
	return 0;
} 

 

全部评论

相关推荐

点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务