Cube Stacking POJ - 1988 (并查集)

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.

  • In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
  • In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.
Input

  • Line 1: A single integer, P

  • Lines 2…P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2

代码一:

#include<iostream>
#include<stdio.h>
#include<stack>
#include<algorithm>
#include<string.h>
using namespace std;
int f[120009];
int up[120009];
int tot[120009];

int find(int x){
    if(f[x]==x) return x;
    else{
        int t=f[x];
        f[x]=find(f[x]);
        up[x]+=up[t];
        return f[x];
    }
}

void uni(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy){
        f[fy]=fx;
        up[fy]+=tot[fx];
        tot[fx]+=tot[fy];
    }
}

int main(){
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        f[i]=i;
        up[i]=0;
        tot[i]=1;
    }
    for(int i=1;i<=n;i++){
        char a;
        getchar();
        scanf("%c",&a);
 // cout<<a<<" * "<<endl;
        if(a=='M'){
            int n1,n2;
            scanf("%d%d",&n1,&n2);
            uni(n1,n2);
        }
        else{
            int u;
            scanf("%d",&u);
            int _u=find(u);
            printf("%d\n",tot[_u]-up[u]-1);
        }

    }
}

代码二

#include<iostream>
#include<stdio.h>
#include<stack>
#include<algorithm>
#include<string.h>
using namespace std;
int f[120009];
int up[120009];
int tot[120009];

int find(int x){
    if(f[x]==x) return x;
    else{
        int t=f[x];
        f[x]=find(f[x]);
        up[x]+=up[t];
        return f[x];
    }
}

void uni(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy){
        f[fy]=fx;
        up[fy]+=tot[fx];
        tot[fx]+=tot[fy];
    }
}

int main(){
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        f[i]=i;
        up[i]=0;
        tot[i]=1;
    }
    for(int i=1;i<=n;i++){
        char a;
        getchar();
        scanf("%c",&a);
 // cout<<a<<" * "<<endl;
        if(a=='M'){
            int n1,n2;
            scanf("%d%d",&n1,&n2);
            uni(n1,n2);
        }
        else{
            int u;
            scanf("%d",&u);
            int _u=find(u);
            printf("%d\n",tot[_u]-up[u]-1);
        }

    }
}
全部评论

相关推荐

球球别再泡了:坏,我单9要了14
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务