HDU - 1162 Eddy's picture (最短路)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11598    Accepted Submission(s): 5853


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
3.41
 

Author
eddy
 

Recommend
JGShining
 
              就是给你n个点~~求连起这n个点的最短路是多少~~做法就是先用个数组存起所有的点~~再把不同的点之间的边存进ed数组(按100个点来算的话也就10100个边)~接着就用并查集加最短路就好了。
#include<iostream>
#include<cstdio>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int fa[105];
struct ***er
{
	double x, y;
}m[105];
struct ***
{
	int to,from;
	double len;
}ed[15000];
int find(int x)
{
	if (x != fa[x])
	{
		fa[x]= find(fa[x]);
	}
	return fa[x];
}
int cnt, n;
void add(int from, int to, double len)
{
	ed[cnt].len = len;
	ed[cnt].to = to;
	ed[cnt].from = from;
	cnt++;
}
void init()
{
	for (int s = 0; s <= 104; s++)
	{
		fa[s] = s;
	}
	cnt = 0;
}
double join(int a, int b)
{
	a = find(a);
	b = find(b);
	if (a!= find(b))
	{
		fa[a] = b;
		return 1;
	}
	return 0;
}
bool cmp(*** a, *** b)
{
	return a.len < b.len;
}
int main()
{
	ios::sync_with_stdio(false);
	while (cin >> n)
	{
		init();
		for (int s = 0; s < n; s++)
		{
			scanf("%lf%lf", &m[s].x, &m[s].y);
		}
		for (int s = 0; s < n; s++)
		{
			for (int e = s + 1; e < n; e++)
			{
				double a = m[s].x - m[e].x;
				double b = m[s].y - m[e].y;
				double len = sqrt(a*a + b*b);
				add(s, e, len);
				add(e, s, len);
			}
		}
		double ans = 0;
		sort(ed, ed + cnt, cmp);
		for (int s = 0; s < cnt; s++)
		{
			int a = ed[s].to;
			int b = ed[s].from;
			double c = join(a, b);
		//	cout << c <<" "<<ed[s].len<< endl;
			ans += c*ed[s].len;
		}
		printf("%.2lf\n", ans);
	}
	return 0;
}



全部评论

相关推荐

评论
点赞
收藏
分享
牛客网
牛客企业服务