Kattis之旅——Number Sets

You start with a sequence of consecutive integers. You want to group them into sets.

You are given the interval, and an integer P. Initially, each number in the interval is in its own set.

Then you consider each pair of integers in the interval. If the two integers share a prime factor which is at least P, then you merge the two sets to which the two integers belong.

How many different sets there will be at the end of this process?

Input

One line containing an integer C, the number of test cases in the input file.

For each test case, there will be one line containing three single-space-separated integers A, B, and P. A and B are the first and last integers in the interval, and P is the number as described above.

Output

For each test case, output one line containing the string "Case #X: Y" where X is the number of the test case, starting from 1, and Y is the number of sets.

Limits

Small dataset

1 <= C <= 10

1 <= A <= B <= 1000

2 <= P <= B

Large dataset

1 <= C <= 100

1 <= A <= B <= 1012

B <= A + 1000000

2 <= P <= B

 

 Sample Input 1 Sample Output 1
2
10 20 5
10 20 3
Case #1: 9
Case #2: 7

题目大概意思就是——给你一个范围A到B,范围中每个数就是一个集合,再给你一个素数P,如果这个范围的两个数有大于或者等于P的素数因子,那么合并两个数所在的集合作为一个集合。

并查集。

#include <iostream>
#include <algorithm>

using namespace std;

typedef long long ll;

static bool test_prime(ll p)
{
    if (p < 2) return false;
    for (ll i = 2; i * i <= p; i++)
        if (p % i == 0)
            return false;
    return true;
}

static int parent[1000001];

static int root(int x)
{
    if (parent[x] < 0)
        return x;
    else
        return parent[x] = root(parent[x]);
}

static void merge(int a, int b)
{
    a = root(a);
    b = root(b);
    if (a == b) return;
    if (parent[a] > parent[b])
        swap(a, b);
    parent[a] += parent[b];
    parent[b] = a;
}

int main()
{
    int cases;
    cin >> cases;

    for (int cas = 0; cas < cases; cas++)
    {
        ll A, B, P;
        cin >> A >> B >> P;

        for (ll i = A; i <= B; i++)
            parent[i - A] = -1;
        for (ll i = P; i <= B - A; i++)
            if (test_prime(i))
            {
                ll t = B - B % i;
                while (t - i >= A)
                {
                    merge(t - A, t - i - A);
                    t -= i;
                }
            }
        ll ans = 0;
        for (ll i = A; i <= B; i++)
            if (parent[i - A] < 0)
                ans++;
        cout << "Case #" << cas + 1 << ": " << ans << "\n";
    }
    return 0;
}

 

全部评论

相关推荐

01-24 12:50
门头沟学院 C++
投票
菜狗二号:还有啥想的 指定国有行啊,去了就开始幸福美满的生活了,选华子不是折腾自己么,最终财富积累度是差不多的,但是幸福指数是相差甚远的
点赞 评论 收藏
分享
2024-12-29 15:37
已编辑
西华大学 图像识别
程序员牛肉:去不了,大厂算法卡学历吧
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务