sdut-B - 233 Matrix
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 … in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333… (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333…) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,…,a n,0, could you tell me a n,m in the 233 matrix?
Input
There are multiple test cases. Please process till EOF.
For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,…,a n,0(0 ≤ a i,0 < 2 31).
Output
For each case, output a n,m mod 10000007.
Sample Input
1 1
1
2 2
0 0
3 7
23 47 16
Sample Output
234
2799
72937
23333333……
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
struct node
{
long long data[15][15];
node()
{
memset(data, 0, sizeof(data));
}
};
int n;
const int mod = 10000007;
node mul(node B, node A)//矩阵相乘
{
int i, j, k;
node C;
for (i = 1; i <= n + 2; i++)
for (j = 1; j <= n + 2; j++)
for (k = 1; k <= n + 2; k++)//此处k是可以放在最外层,
C.data[i][j] = (C.data[i][j] + B.data[i][k] * A.data[k][j]) % mod;
return C;
}
node f(node A, int m)
{
node ans;
for (int i = 1; i <= n + 2; i++)//这是一个单位矩阵。
ans.data[i][i] = 1;
while (m > 0)
{
if (m & 1)//满足条件,相乘一波
{
ans = mul(ans, A);
}
A = mul(A, A);//无论如何,自乘一波
m >>= 1;
}
return ans;
}
int main()
{
int m;
while (scanf("%d%d", &n, &m) != EOF)
{
node A, B;
{
//对矩阵赋初值
A.data[1][1] = 23;
for (int i = 1; i <= n; i++)
scanf("%lld", &A.data[i + 1][1]);
A.data[n + 2][1] = 3;
for (int i = 1; i <= n + 1; i++)
B.data[i][1] = 10;
for (int i = 1; i <= n + 2; i++)
B.data[i][n + 2] = 1;
for (int i = 1; i < n + 2; i++)
for (int j = 2; j <= i; j++)
B.data[i][j] = 1;
}
B = f(B, m);
A = mul(B, A);
cout << A.data[n + 1][1] << endl;
}
return 0;
}