遍历二叉树

数据结构实验之二叉树二:遍历二叉树

已知二叉树的一个按先序遍历输入的字符序列,如abc,de,g,f, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。
Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output
每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Sample Input
abc,de,g,f,

Sample Output
begdfa
cgefdba

#include <bits/stdc++.h>
#include<cstring>
#include<cstdio>
using namespace std;
struct node
{
   
    char data;
    node *l;
    node *r;
};
char s[100];
int i;
node *plant()//前序建立
{
   
    if(s[i]==',')
    {
   
        i++;
        return NULL;
    }
    node *root;
    root=new node;
    root->data=s[i++];
    root->l=plant();
    root->r=plant();
    return root;
};
void mid(node *root)//中序遍历
{
   
    if(root==NULL)
    {
   
        return;
    }
    mid(root->l);
    cout<<root->data;
    mid(root->r);
}
void bhi(node *root)//后序遍历
{
   
    if(root==NULL)
    {
   
        return;
    }
    bhi(root->l);
    bhi(root->r);
    cout<<root->data;
}
int main()
{
   
    while(cin>>s)
    {
   
        i=0;
        node *root=plant();
        mid(root);
        cout<<endl;
        bhi(root);
        cout<<endl;
    }
    return 0;
}
全部评论

相关推荐

2024-12-27 10:21
已编辑
海南师范大学 媒介策划
到我怀里来:身高体重住址这些就别写了,留几个关键的就行,工作经历突出重点写详细点
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务