hdu 5547 数独(DFS)

hdu 5547 数独(DFS)

原题目
Problem Description
Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you’ve passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of ‘1’, ‘2’, ‘3’, ‘4’). ‘*’ represents that number was removed by Yi Sima.

It’s guaranteed that there will be exactly one way to recover the board.

Output
For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

Sample Input
3


2341
4123
3214
*243
312
421
134
41
*3
2
41
4
2

Sample Output
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

思路

判断横竖以及四个方格中是否有相同数字
依次搜索中,最后记录数字输出。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
char maps[10][10];
int panduan(int row, int col)
{
   
    for(int i=0; i<4; i++)//判断列
    {
   
        if(maps[row][i]==maps[row][col]&&i!=col)
            return 0;
    }
    for(int i=0; i<4; i++)//判断行
    {
   
        if(maps[i][col]==maps[row][col]&&i!=row)
            return 0;
    }

    int Row, Col;//判断四方格
    if(row%2==1) Row=row-1;
    else Row=row;

    if(col%2==1) Col=col-1;
    else Col=col;

    for(int i=Row; i<=Row+1; i++)
    {
   
        for(int j=Col; j<=Col+1; j++)
        {
   
            if(maps[i][j]==maps[row][col]&&i!=row&&j!=col)
                return 0;
        }
    }
    return 1;
}

void DFS(int t)
{
   
    if(t==16)
    {
   
        for(int i=0; i<4; i++)
            puts(maps[i]);
        return ;
    }

    int row=t/4;
    int col=t%4;

    if(maps[row][col]=='*')
    {
   
        for(int i=1; i<=4; i++)
        {
   
            maps[row][col]=i+'0';
            if(panduan(row, col))
                DFS(t+1);
			maps[row][col]='*';
	        }
    }
    else
        DFS(t+1);
}

int main()
{
   
    int T, cas=1;
    scanf("%d", &T);

    while(T--)
    {
   
        for(int i=0; i<4; i++)
            scanf("%s", maps[i]);

        printf("Case #%d:\n", cas++);

        DFS(0);
    }
    return 0;
}

总结

思路很简单 判断时需要注意是不是自己等于自己依次判断,无异常返回1即可。

全部评论

相关推荐

11-01 08:48
门头沟学院 C++
伤心的候选人在吵架:佬你不要的,能不能拿户口本证明过户给我。。球球了
点赞 评论 收藏
分享
没有offer的小土豆:专业面试一般是分配面试官然后联系你面试 应该是还没给你分配对应面试官
点赞 评论 收藏
分享
11-26 22:34
已编辑
重庆邮电大学 Java
快手 客户端开发 (n+5)k*16 公积金12
牛客895077908号:佬 什么双非硕啊
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务