dfs Red and Black

Submit Status

Description

Input

Output

Sample Input

Sample Output

Hint

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int n, m;
int chess[25][25];
bool visited[25][25];
int d[4][2] = { 0,1,1,0,-1,0,0,-1 };
int sum = 0;
void dfs(int x,int y)
{
	int tx, ty;
	for(int i=0;i<4;i++)
	{
		tx = x + d[i][0];
		ty = y + d[i][1];
		if (tx < 0 || tx >= n || ty<0 || ty>=m || chess[ty][tx]=='#' || visited [ty][tx]==true)
		{
			continue;
		}
		visited[ty][tx] = true;
		sum += 1;
		dfs(tx, ty);
	}
}
int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		sum = 0;
		memset(visited, false, sizeof(visited));
		int x, y;
		if (n == 0 && m == 0) { break; }
		getchar();
		for(int i=0;i<m;i++)
		{
			for(int j=0;j<n;j++)
			{
				scanf("%c", &chess[i][j]);
				if(chess[i][j]=='@')
				{
					x = j;
					y = i;
				}
			}
			getchar();
		}
		visited[y][x] = true;
		sum+=1;
		dfs(x, y);
		printf("%d\n", sum);
	}
	return 0;
}

//by tp
全部评论

相关推荐

饼子吃到撑:海面这个是,投了一般都给的
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务