dfs 变形课

呃......变形课上Harry碰到了一点小麻烦,因为他并不像Hermione那样能够记住所有的咒语而随意的将一个棒球变成刺猬什么的,但是他发现了变形咒语的一个统一规律:如果咒语是以a开头b结尾的一个单词,那么它的作用就恰好是使A物体变成B物体.
Harry已经将他所会的所有咒语都列成了一个表,他想让你帮忙计算一下他是否能完成老师的作业,将一个B(ball)变成一个M(Mouse),你知道,如果他自己不能完成的话,他就只好向Hermione请教,并且被迫听一大堆好好学习的道理.
Input <dl><dd> 测试数据有多组。每组有多行,每行一个单词,仅包括小写字母,是Harry所会的所有咒语.数字0表示一组输入结束.
</dd> Output <dd> 如果Harry可以完成他的作业,就输出"Yes.",否则就输出"No."(不要忽略了句号)
</dd> Sample Input <dd>
so
soon
river
goes
them
got
moon
begin
big
0
</dd> Sample Output <dd>
Yes.
</dd> <dd>
wrong了半天发现是大小写错了==尴尬
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
struct node
{
	char head, end;
};
node incantation[10000];

char temp[20];
int i;
//int stratnum[10000];
bool can;
bool in_sign[10000];
void dfs(char k)
{


	if (k == 'm')
	{
		can = true;
		return;
	}

	for (int j = 0; j < i; j++)
	{
		if (incantation[j].head == k && in_sign[j] == false)
		{
			in_sign[j] = true;
			dfs(incantation[j].end);
			in_sign[j] = false;
		}
	}

}
int main()
{
		while (~scanf("%s", temp))
		{
			i = 0;
			if (!strcmp(temp, "0")) { continue; }
			can = false;
			incantation[i].head = temp[0];
			incantation[i++].end = temp[strlen(temp) - 1];
			while (scanf("%s", temp), strcmp(temp, "0"))
			{
				incantation[i].head = temp[0];
				incantation[i++].end = temp[strlen(temp) - 1];
			}
				for (int p = 0; p < i; p++)
				{
					memset(in_sign, false, sizeof(in_sign));
					if (incantation[p].head == 'b')
					{
						in_sign[p] = true;
						dfs(incantation[p].end);
					}
					if (can == true)
					{
						
						break;
					}
				}
				if(can==false)
				{
					printf("No.\n");
				}
				else printf("Yes.\n");
			}
			return 0;
		}

</dd> </dl>
全部评论

相关推荐

10-24 11:10
山西大学 Java
若梦难了:哥们,面试挂是很正常的。我大中厂终面挂,加起来快10次了,继续努力吧。
点赞 评论 收藏
分享
我见java多妩媚:大外包
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务