数塔
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗? Input <dl><dd> 输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间 0,99 0,99内。
</dd> Output <dd> 对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
</dd> Sample Input <dd>
</dd> </dl>
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗? Input <dl><dd> 输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间 0,99 0,99内。
</dd> Output <dd> 对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
</dd> Sample Input <dd>
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5</dd> Sample Output <dd>
30
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int high;
int tower[105][105];
int vis[105][105];
int d[2][2] = { 1,0,1,1 };
int dfs(int x, int y)
{
if (vis[x][y]) { return vis[x][y]; }
int Max = 0;
for(int i=0;i<2;i++)
{
int tx = x + d[i][0];
int ty = y + d[i][1];
if(tx<0 || tx>=high || ty<0 || ty>= tx+1 )
{
continue;
}
Max = max(Max, dfs(tx, ty));
}
vis[x][y] = Max + tower[x][y];
return vis[x][y];
}
int main()
{
int n;
scanf("%d", &n);
while(n--)
{
scanf("%d", &high);
for(int i=0;i<high;i++)
{
for(int j=0;j<i+1;j++)
{
scanf("%d", &tower[i][j]);
}
}
memset(vis, 0, sizeof(vis));
int ans=dfs(0, 0);
printf("%d\n", ans);
}
return 0;
}
</dd> </dl>