HDU233 还是畅通工程(最小生成树)

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input <dl><dd> 测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
</dd> Output <dd> 对每个测试用例,在1行里输出最小的公路总长度。
</dd> Sample Input <dd>
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
</dd> Sample Output <dd>
3
5
</dd> <dd>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;

struct node
{
	int from, to, distance;

};
node hu[10005];
int already[10005];


bool cmp(node x, node y)
{
	return x.distance < y.distance;
}

int _find(int x)
{
	if (already[x] == x)
	{
		return x;
	}
	else
	{
		return already[x] = _find(already[x]);
	}
}


bool merge(int x, int y)
{
	int xx = _find(x);
	int yy = _find(y);
	if (xx == yy)
	{
		return false;
	}
	already[xx] = yy;
	return true;
}

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		if (n == 0)
		{
			break;
		}
		const int N = n*(n - 1) / 2;
		for (int i = 0; i < N; i++)
		{
			scanf("%d %d %d", &hu[i].from, &hu[i].to, &hu[i].distance);
		}
		sort(hu,hu+N,cmp);

		for (int i = 1; i <= n; i++)
		{
			already[i] = i;
		}
		int sum = 0, count = 0;
		for (int i = 0; i <N; i++)
		{
			
			if (merge(hu[i].from, hu[i].to))
			{
				count++;
				sum += hu[i].distance;
			}
			if(count==n-1)
			{
				break;
			}
			
		}
		printf("%d\n", sum);
	}
	return 0;
}

</dd> </dl>
全部评论

相关推荐

头像
11-07 01:12
重庆大学 Java
精致的小松鼠人狠话不多:签哪了哥
点赞 评论 收藏
分享
牛客771574427号:恭喜你,华杰
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务