二分二分

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[1000005];
int main()
{
   
	int ans;
	int n,k;
	while(scanf("%d",&n)!=EOF)
	{
   
	
	for(int i=1;i<=n;i++)
	scanf("%d",&a[i]);
	scanf("%d",&k);
	sort(a,a+n+1);
	if(k==1)
	{
   
		printf("%d\n",a[n]);
		continue;
	}
	int l=1,r=a[n];
	while(l<=r)
	{
   
		int cnt=0;
		int mid=(l+r)/2;
		for(int i=1;i<=n;i++)
		{
   
			if(a[i]<mid)
			{
   continue;
			}
			else
			{
   
				cnt+=ceil(1.0*(a[i]-mid)/(k-1)); //ceil向上取整 注意乘上1.0 让它变成double
			}
			if(cnt>mid)	break;
		}
		if(cnt<=mid)
		{
   ans=mid;
		r=mid-1;
		}
		else
		{
   l=mid+1;
		}
	}
	printf("%d\n",ans); } 
	return 0;
 } 
全部评论

相关推荐

牛客935420688号:这公司幽默得很,要了简历半天一点动静都没有,过一会就给你发个邮件让你做测试,做完又没后文了,纯溜人
点赞 评论 收藏
分享
黑皮白袜臭脚体育生:简历统一按使用了什么技术实现了什么功能解决了什么问题或提升了什么性能指标来写会更好另外宣传下自己的开源仿b站微服务项目,GitHub已经410star,牛客上有完整文档教程,如果觉得有帮助的话可以点个小星星,蟹蟹
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务