HDU - 5056(尺取)

Boring count

Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output For each case, output a line contains the answer.
Sample Input3
abc
1
abcabc
1
abcabc
2
Sample Output6
15
21

尺取法。在网上搜的题解

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn=1e5+5;
int k,len,cnt[200];
char s[maxn];
bool check()
{
   
    for(char i='a';i<='z';i++)
        if(cnt[i]>k)
            return false;
    return true;
}
int main()
{
   
    int t;
    scanf("%d",&t);
    while(t--)
    {
   
        memset(cnt,0,sizeof(cnt));
        cin>>s;
        scanf("%d",&k);
        len=strlen(s);
        long long ans=0;
        for(int i=0,j=0;i<len;i++)
        {
   
            cnt[s[i]]++;
            while(check()==false)
            {
   
                cnt[s[j]]--;
                j++;
            }
            ans+=i-j+1;
        }
        cout<<ans<<'\n';
    }
    return 0;
}

全部评论

相关推荐

像好涩一样好学:这公司我也拿过 基本明确周六加班 工资还凑活 另外下次镜头往上点儿
点赞 评论 收藏
分享
10-25 12:05
已编辑
湖南科技大学 Java
若梦难了:我有你这简历,已经大厂乱杀了
点赞 评论 收藏
分享
1 收藏 评论
分享
牛客网
牛客企业服务