ZOJ3702(打表)

Gibonacci number
In mathematical terms, the normal sequence F(n) of Fibonacci numbers is defined by the recurrence relation
F(n)=F(n-1)+F(n-2)
with seed values
F(0)=1, F(1)=1
In this Gibonacci numbers problem, the sequence G(n) is defined similar
G(n)=G(n-1)+G(n-2)
with the seed value for G(0) is 1 for any case, and the seed value for G(1) is a random integer t, (t>=1). Given the i-th Gibonacci number value G(i), and the number j, your task is to output the value for G(j)

Input

There are multiple test cases. The first line of input is an integer T < 10000 indicating the number of test cases. Each test case contains 3 integers i, G(i) and j. 1 <= i,j <=20, G(i)<1000000

Output

For each test case, output the value for G(j). If there is no suitable value for t, output -1.

Sample Input

4
1 1 2
3 5 4
3 4 6
12 17801 19

Sample Output

2
8
-1
516847

斐波那契的变形,推个公式,G(n)=F(n-1)*G(1)+F(n-2)
注意n取1的时候和G(n)为负值的时候,注意数组边界

#include<bits/stdc++.h>
using namespace std;
int main()
{
   
    long long i,n,t,tmp1,tmp2,tmp3,b,c,d;
    long long a[100];
    a[0]=1;
    a[1]=1;
    a[2]=2;
    for(i=3; i<=40; i++)
        a[i]=a[i-1]+a[i-2];
    scanf("%lld",&t);
    while(t--)
    {
   
        scanf("%lld%lld%lld",&tmp1,&tmp2,&tmp3);
        b=1;
        c=0;
        d=0;
        if(tmp1==1)
        {
   
            c=tmp2;
            if(tmp3==1)
                cout<<c<<'\n';
            else
            {
   
                d=a[tmp3-1]*c+a[tmp3-2];
                cout<<d<<'\n';
            }
        }
        else
        {
   
            c=(tmp2-a[tmp1-2])/a[tmp1-1];
            if(c*a[tmp1-1]!=tmp2-a[tmp1-2]||c<=0)
            {
   
                cout<<"-1"<<'\n';
            }
            else
            {
   
                if(tmp3==1)
                    cout<<c<<'\n';
                else
                {
   
                    d=a[tmp3-1]*c+a[tmp3-2];
                    cout<<d<<'\n';
                }
            }
        }
    }
    return 0;
}

全部评论

相关推荐

服从性笔试吗,发这么多笔,现在还在发。
蟑螂恶霸zZ:傻 x 公司,发两次笔试,两次部门匹配挂,
投递金山WPS等公司10个岗位 >
点赞 评论 收藏
分享
字节 飞书绩效团队 (n+2) * 15 + 1k * 12 + 1w
点赞 评论 收藏
分享
点赞 评论 收藏
分享
2 收藏 评论
分享
牛客网
牛客企业服务