sdnuoj1292(LIS)
Description
昨天是平安夜,圣诞老人从房顶上的烟囱里爬到小朋友床边把礼物送给梦乡中的小朋友,但是今年的圣诞老人是处女座的,他有很严重的强迫症,他从一条街的一端开始,每次送礼物进的烟囱都不能比之前进的烟囱高,而且他还想要送出最多的礼物。
Input
输入数据只有一行,该行包含若干个数据,表示一条街上的烟囱高度(烟囱最多有 20 枚,高度h≤1000000)。
Output
圣诞老人最多送出多少礼物。
Sample Input
315 199 155 301 215 170 150 25
Sample Output
6
dp模板题
#include<bits/stdc++.h>
using namespace std;
int main()
{
int i,j,t,n,ans,cnt,a[25],dp[25];
cnt=0;
while(scanf("%d",&n)!=EOF)
{
a[cnt++]=n;
}
ans=0;
dp[0]=1;
for(i=1;i<cnt;i++)
{
dp[i]=1;
for(j=0;j<i;j++)
{
if(a[j]>=a[i])
{
if(dp[i]<dp[j]+1)
{
dp[i]=dp[j]+1;
}
}
}
ans=ans>dp[i]?ans:dp[i];
}
cout<<ans<<'\n';
return 0;
}