sdnu1062.Fibonacci(矩阵快速幂模板)
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2.
Input
a single line containing n (where 0 ≤ n ≤ 100,000,000,000)
Output
print Fn mod 1000000007 in a single line.
Sample Input
99999999999
Sample Output
669753982
Hint
An alternative formula for the Fibonacci sequence is
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
矩阵快速幂 求斐波那契 模板
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=2;
const int mod=1000000007;
struct mat
{
ll a[N][N];
};
mat mat_mul(mat x,mat y)
{
mat res;
memset(res.a,0,sizeof(res.a));
for(int i=0;i<2;i++)
{
for(int j=0;j<2;j++)
{
for(int k=0;k<2;k++)
res.a[i][j]=(res.a[i][j]+x.a[i][k]*y.a[k][j])%mod;
}
}
return res;
}
long long mat_pow(ll n)
{
mat c,res;
c.a[0][0]=c.a[0][1]=c.a[1][0]=1;
c.a[1][1]=0;
memset(res.a,0,sizeof(res.a));
for(int i=0;i<2;i++)
res.a[i][i]=1;
while(n)
{
if(n&1)
res=mat_mul(res,c);
c=mat_mul(c,c);
n=n>>1;
}
return res.a[1][0];
}
int main()
{
ll n;
while(scanf("%lld",&n)!=EOF)
{
long long tmp=mat_pow(n);
cout<<tmp<<'\n';
}
}