LightOJ - 1341 Aladdin and the Flying Carpet (素数筛+唯一分解定理+约数个数和)
It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.
Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.
Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.
Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output
For each case, print the case number and the number of possible carpets.
Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2
It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.
Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.
Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.
Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output
For each case, print the case number and the number of possible carpets.
Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2
真的是WA+RE了好多次
普及一下唯一分解定理的应用https://www.cnblogs.com/Lis-/p/9692677.html
#include <bits/stdc++.h>
using namespace std;
const long long N=1e6+100;
bool vis[N];
long long prime[N];
long long tot=1;
void Er()
{
memset(vis,0,sizeof(vis));
vis[0]=vis[1]=1;
for(long long i=2;i<N;i++)
{
if(!vis[i])
{
prime[tot++]=i;
for(long long j=i*2;j<N;j+=i)
vis[j]=1;
}
}
}
int main()
{
Er();
int t;
long long a,s;
scanf("%d",&t);
for(int kcase=1;kcase<=t;kcase++)
{
scanf("%lld%lld",&s,&a);
long long ans=1;
if(a>=sqrt(s))
ans=0;
else
{
long long s1=s;
long long i=1;
while(s>1&&i<tot)
{
long long tmp=0;
while(s%prime[i]==0)
{
tmp++;
s/=prime[i];
}
ans*=(tmp+1);
i++;
}
if(s!=1)
ans*=2;
ans/=2;
for(long long i=1; i<a; i++)
if(s1%i==0)
ans--;
if(ans<0)
ans=0;
}
cout<<"Case "<<kcase<<": "<<ans<<'\n';
}
return 0;
}